help > Doesn't show the connectivity or edges
Showing 1-9 of 9 posts
Display:
Results per page:
Apr 11, 2019  02:04 AM | Hashini Wanniarachchi
Doesn't show the connectivity or edges
Hello Community,

I'm very new to Brain Net View tool. I was trying to use this for custom layout. I get the nodes drawn properly, but it doesn't show the edges in the image. In the matlab, I see the following error. 

Operands to the || and && operators must be convertible to logical scalar
values.

Error in BrainNet_Option>Initialization (line 348)
if
EC.lbl_threshold>max(surf.sphere(:,5))||EC.lbl_threshold
Error in BrainNet_Option>BrainNet_Option_OpeningFcn (line 79)
Initialization(handles);
Error in gui_mainfcn (line 220)
feval(gui_State.gui_OpeningFcn, gui_hFigure, [], guidata(gui_hFigure),
varargin{:});
Error in BrainNet_Option (line 52)
[varargout{1:nargout}] = gui_mainfcn(gui_State, varargin{:});
Error in BrainNet>NV_m_LF_Callback (line 4774)
H=BrainNet_Option;
Error in gui_mainfcn (line 95)
feval(varargin{:});
Error in BrainNet (line 53)
gui_mainfcn(gui_State, varargin{:});
Error in
matlab.graphics.internal.figfile.FigFile/read>@(hObject,eventdata)BrainNet('NV_m_LF_Callback',hObject,eventdata,guidata(hObject))
Error while evaluating Menu Callback.


Please help!

I don't understand where to and what to fix. 

Thank you in advance
Attachment: test.node
Apr 11, 2019  06:04 AM | Mingrui Xia
RE: Doesn't show the connectivity or edges
Hi, could you please save the option configuration and attach with also your edge file? We can have a test. 

Thanks
Mingrui
Originally posted by Hashini Wanniarachchi:
Hello Community,

I'm very new to Brain Net View tool. I was trying to use this for custom layout. I get the nodes drawn properly, but it doesn't show the edges in the image. In the matlab, I see the following error. 

Operands to the || and && operators must be convertible to logical scalar
values.

Error in BrainNet_Option>Initialization (line 348)
if
EC.lbl_threshold>max(surf.sphere(:,5))||EC.lbl_threshold
Error in BrainNet_Option>BrainNet_Option_OpeningFcn (line 79)
Initialization(handles);
Error in gui_mainfcn (line 220)
feval(gui_State.gui_OpeningFcn, gui_hFigure, [], guidata(gui_hFigure),
varargin{:});
Error in BrainNet_Option (line 52)
[varargout{1:nargout}] = gui_mainfcn(gui_State, varargin{:});
Error in BrainNet>NV_m_LF_Callback (line 4774)
H=BrainNet_Option;
Error in gui_mainfcn (line 95)
feval(varargin{:});
Error in BrainNet (line 53)
gui_mainfcn(gui_State, varargin{:});
Error in
matlab.graphics.internal.figfile.FigFile/read>@(hObject,eventdata)BrainNet('NV_m_LF_Callback',hObject,eventdata,guidata(hObject))
Error while evaluating Menu Callback.


Please help!

I don't understand where to and what to fix. 

Thank you in advance
Apr 11, 2019  10:04 AM | Hashini Wanniarachchi
RE: Doesn't show the connectivity or edges
Hi Mingrui,

Thank you for your reply.
I believe this is the option configuration file. I will attach the edge file too
Attachment: bnv.mat
Apr 11, 2019  10:04 AM | Hashini Wanniarachchi
RE: Doesn't show the connectivity or edges
This is the edge file
Attachment: edge_ex.edge
Apr 11, 2019  06:04 PM | Mingrui Xia
RE: Doesn't show the connectivity or edges
Hi, this error is because of the nonstandard format of node file. There is an unexpected character in line 76 and the file was not encoded in UTF-8. Please try the attached modified node file. Thanks.

Best,
Mingrui

Originally posted by Hashini Wanniarachchi:
Hi Mingrui,

Thank you for your reply.
I believe this is the option configuration file. I will attach the edge file too
Attachment: test.node
Apr 11, 2019  09:04 PM | Hashini Wanniarachchi
RE: Doesn't show the connectivity or edges
Hi Mingrui,

This is still what I get even after using edited nodes file. I wonder what's wrong.

Thank you for your support!!!
Attachment: bnv.jpg
Apr 11, 2019  10:04 PM | Hashini Wanniarachchi
RE: Doesn't show the connectivity or edges
Hi Mingrui,

When I use standalone version, it came out good. 

Thanks for this tool!

Will make sure to cite your great work!

Hashini W
Apr 11, 2019  11:04 PM | Mingrui Xia
RE: Doesn't show the connectivity or edges
Hi. Could you please paste the error message? 

It seems that the node file works but something wrong with the edges.
Originally posted by Hashini Wanniarachchi:
Hi Mingrui,

This is still what I get even after using edited nodes file. I wonder what's wrong.

Thank you for your support!!!
Apr 12, 2019  04:04 AM | Mingrui Xia
RE: Doesn't show the connectivity or edges
Hi Hashini, 

It worked well on matlab version of my laptop. Anyway, glad to see you figure it out. 

Thanks
Mingrui
Originally posted by Hashini Wanniarachchi:
Hi Mingrui,

When I use standalone version, it came out good. 

Thanks for this tool!

Will make sure to cite your great work!

Hashini W
Attachment: Fig.tif