help > Error message in output - ABC_CLI, ABC_Segementation
Showing 1-2 of 2 posts
Display:
Results per page:
Jul 18, 2019  09:07 AM | Pearlynne C
Error message in output - ABC_CLI, ABC_Segementation
Hi!

I am processing the images with T1, T2, and the subject's brain mask, and using pediatric-atlas-1year-T1-ABC for tissue segmentation. Even though the analyses were completed, I have received the following errors for all outputs.

While running : /home/chong30/anaconda3/envs/mri/bin/python3
Following error(s) occured :
While running : /home/chong30/Auto_EACSF-release-v1.3/usr/bin/ABC_CLI /home/chong30/Auto_EACSF-release-v1.3/usr/bin/ABC_CLI /home/chong30/Output/ABCparam.xml Following error(s) occured : Run without any arguments to see command line options Failed opening /home/chong30/Output/ABC_Segmentation/file_stripped_to_template_EMS.affine

I am not sure what it means and how to address that. 

Thank you for your help!

Regards,
Pearlynne
Jul 18, 2019  09:07 AM | Martin Styner
RE: Error message in output - ABC_CLI, ABC_Segementation
Hi Pearlynne
This is actually not an error and an ongoing issue with ABC (one of the tools called by Auto_EACSF). As part of running ABC, it checks whether a prior affine registration exists. If not then it computes such an affine registration. Thus, this error is more: "Hey, FYI, I am going to compute an affine registration as I could not find one already done".

So, no need to address this error (as it is not really an error, and you should see this happening every time you run Auto_EACSF if you do not provide a prior tissue segmentation and ABC needs to be run).

Martin
Originally posted by Pearlynne C:
Hi!

I am processing the images with T1, T2, and the subject's brain mask, and using pediatric-atlas-1year-T1-ABC for tissue segmentation. Even though the analyses were completed, I have received the following errors for all outputs.

While running : /home/chong30/anaconda3/envs/mri/bin/python3
Following error(s) occured :
While running : /home/chong30/Auto_EACSF-release-v1.3/usr/bin/ABC_CLI /home/chong30/Auto_EACSF-release-v1.3/usr/bin/ABC_CLI /home/chong30/Output/ABCparam.xml Following error(s) occured : Run without any arguments to see command line options Failed opening /home/chong30/Output/ABC_Segmentation/file_stripped_to_template_EMS.affine

I am not sure what it means and how to address that. 

Thank you for your help!

Regards,
Pearlynne