sdm-help-list > sdm_parse not working
Showing 1-6 of 6 posts
Display:
Results per page:
Aug 2, 2020  08:08 AM | tmp
sdm_parse not working
Hi,

when running the FWE correction I get the system error "sdm_parse is not working". SDM itself is not giving me an error. I'm attaching the execution log. I recently installed the new SDM version, I didn't have this error with the same analysis in the older version (6.12rc). Hope you can help!

Thank you!

Tania
Attachment: ExecLog.txt
Aug 3, 2020  08:08 AM | Lydia Fortea - Instituto de Investigaciones Biom├ędicas August Pi i Sunyer (IDIBAPS)
RE: sdm_parse not working
Dear Tania, 

Unfortunately, the execution log seems to work correctly and we don't have enough time right now to check the bugs. Maybe you can check  from "Preferences" that the "Core Binaries" are linked to the current version of SDM, as well as try to install again the software.

Sorry for the inconveniences,
Kind regards,
Lydia
Aug 5, 2020  02:08 AM | tmp
RE: sdm_parse not working
Dear Lydia,

thank you for your reply!

I have tried re-installing SDM and also checked the bins, everything seems to be in order. Unfortunately this did not solve the problem. I have also tried on several different computers, so it doesn't seem to be a problem that's only on my computer.

Unfortunately I have also encountered more errors. Maybe the additional information could help point into the direction of the cause?

First, when running a linear model I have encountered the following error (I'm attaching the log): "WARNING: ID 'analysis_LinearModelGMD_age_gender_edu_ctq/mi/i00000/meta_I00000_var' not found. The program will close as this problem could cause fatal errors."

On a different computer I have encountered this error when running the linear model: "matrix is singular Default GSL error handler invoked" (I'm attaching a picture of the whole error message and the log).

Lastly, I get warning messages about files foobin, foothr, foomul not being found when Thresholding. The process keeps running, though. I'm also attaching the log.

I hope you'll be able to point me in a direction of what else I could try. Otherwise I'll run the analyses with version 6.12rc, do you think that will make a major difference? In that case, which mask would you recommend for Cortical Thickness analyses?

Thank you, I really appreciate your support!

Best, Tania
Attachment: errors.zip
Aug 7, 2020  05:08 AM | Anton Albajes-Eizagirre - FIDMAG - Germanes Hospitalaries
RE: sdm_parse not working
Hi Tania,

Let's try to attack one problem at a time :)


The singular matrix problem: What is your sdm table?

Best,

Anton

P.S. I noticed on one of your error logs that you are using a path with space characters (D:\Working Folder CT/). I would discourage you to use paths with spaces on it, as SDM sometimes has problems with them.

Originally posted by tmp:
Dear Lydia,

thank you for your reply!

I have tried re-installing SDM and also checked the bins, everything seems to be in order. Unfortunately this did not solve the problem. I have also tried on several different computers, so it doesn't seem to be a problem that's only on my computer.

Unfortunately I have also encountered more errors. Maybe the additional information could help point into the direction of the cause?

First, when running a linear model I have encountered the following error (I'm attaching the log): "WARNING: ID 'analysis_LinearModelGMD_age_gender_edu_ctq/mi/i00000/meta_I00000_var' not found. The program will close as this problem could cause fatal errors."

On a different computer I have encountered this error when running the linear model: "matrix is singular Default GSL error handler invoked" (I'm attaching a picture of the whole error message and the log).

Lastly, I get warning messages about files foobin, foothr, foomul not being found when Thresholding. The process keeps running, though. I'm also attaching the log.

I hope you'll be able to point me in a direction of what else I could try. Otherwise I'll run the analyses with version 6.12rc, do you think that will make a major difference? In that case, which mask would you recommend for Cortical Thickness analyses?

Thank you, I really appreciate your support!

Best, Tania
Aug 8, 2020  06:08 AM | tmp
RE: sdm_parse not working
Hi Anton,

thanks for the tip, I will avoid the spaces in the future!

I'm attaching the sdm table the singular matrix problem occurred with. :)

Best,

Tania
Originally posted by Anton Albajes-Eizagirre:
Hi Tania,

Let's try to attack one problem at a time :)


The singular matrix problem: What is your sdm table?

Best,

Anton

P.S. I noticed on one of your error logs that you are using a path with space characters (D:\Working Folder CT/). I would discourage you to use paths with spaces on it, as SDM sometimes has problems with them.

Originally posted by tmp:
Dear Lydia,

thank you for your reply!

I have tried re-installing SDM and also checked the bins, everything seems to be in order. Unfortunately this did not solve the problem. I have also tried on several different computers, so it doesn't seem to be a problem that's only on my computer.

Unfortunately I have also encountered more errors. Maybe the additional information could help point into the direction of the cause?

First, when running a linear model I have encountered the following error (I'm attaching the log): "WARNING: ID 'analysis_LinearModelGMD_age_gender_edu_ctq/mi/i00000/meta_I00000_var' not found. The program will close as this problem could cause fatal errors."

On a different computer I have encountered this error when running the linear model: "matrix is singular Default GSL error handler invoked" (I'm attaching a picture of the whole error message and the log).

Lastly, I get warning messages about files foobin, foothr, foomul not being found when Thresholding. The process keeps running, though. I'm also attaching the log.

I hope you'll be able to point me in a direction of what else I could try. Otherwise I'll run the analyses with version 6.12rc, do you think that will make a major difference? In that case, which mask would you recommend for Cortical Thickness analyses?

Thank you, I really appreciate your support!

Best, Tania
Attachment: SDM_table.txt
Aug 12, 2020  12:08 AM | tmp
RE: sdm_parse not working
Hi Anton,

now I'm receiving this error "WARNING: ID 'analysis_GMVMaltreatment_LinearModel_Filtered_AgeGender/mi/i00000/meta_I00000' not found.
The program will close as this problem could cause fatal errors." on a computer where I have previously been able to run the linear model without problems. I have not changed anything so I don't know what could have caused this. I'm using version 6.12rc (because the newer version doesn't gives me the other error) and have tried re-installing it, but it hasn't helped.

I hope you can help me figure this out. Thank you!

Best,
Tania