users > Error loading library liblzmadec
Showing 1-5 of 5 posts
Display:
Results per page:
Nov 11, 2010  06:11 PM | Clive Wong
Error loading library liblzmadec
Hi,

I've tried to use the toolkit in both linux (ubuntu 10.10) and Mac (Snow Leopard), both OS give me same error massage

Ubuntu
error while loading shared libraries: liblzmadec.so.0: cannot open shared object file: No such file or directory

Mac:
dyld: Library not loaded: /opt/local/lib/liblzmadec.0.dylib
Referenced from: /Users/clive/Imaging/CMTK-1.4.3-Darwin-i386/bin/describe
Reason: image not found
Trace/BPT trap

Is there any library I've missed?

Thanks,
Clive
Nov 11, 2010  08:11 PM | Torsten Rohlfing
RE: Error loading library liblzmadec
Hi Clive:

Sorry about the inconvenience. It seems that Debian (and thus Ubuntu I guess) does not supply that library at all. I guess we'll configure the binaries without it in the future. Not sure why it doesn't work on the Mac, where apparently our build system has the lib, but we'll just change the build option there too.

I will open a bug for this, and it should be resolved in the upcoming 1.5.0 release.

In the meantime, can you build directly from source? That should be quite simple and will resolve all issues with missing libraries.

Best,
Torsten
Nov 11, 2010  09:11 PM | Clive Wong
RE: Error loading library liblzmadec
Dear Torsten,

Thank you for your quick response.

I've just compiled it. It works, thank you.

Best,
Clive
Nov 11, 2010  10:11 PM | Greg Jefferis
RE: Error loading library liblzmadec
The MacOS X build doesn't work because that library is not supplied by
default. If you use otool to inspect the binaries you can see that they
are trying to link to a dynamic library located in /opt which is a
separate tree installed by macports which will often not be on user
machines. It would therefore make sense not to compile with that
support on the build machine or figure out a static link or include the
dynamic library.

While on the same topic the current mac binaries only run on 10.6 and
are all x86_64 - I think that the CMake config files for 10.4 and 10.5
were ignored at config time. Best,

Greg.
Nov 18, 2010  10:11 AM | Torsten Rohlfing - Google LLC
RE: Error loading library liblzmadec
Greg:

I think the problem with the config files was that they were not using CMake's "SET( ... CACHE ... )" syntax, so none of the settings made it into the cache file. I am currently testing a fix for this, which should appear in SVN soon.

TR