general-discussion > cp or mv commands wait for overwrite confirm
Showing 1-3 of 3 posts
Display:
Results per page:
Dec 9, 2010  05:12 AM | Alexis Machado
cp or mv commands wait for overwrite confirm
Hi
I work on the BIC servers on linux machine ( debian system ( not sure)).
When i lauched some brick functions individually ( i have not tested the psom manager) matlab can stay busy when he call some cp or mv commands.

i.e :Reading T1 image /mfip/mfip1/alexis/TUTORIALS/NIAK/ResultsMyDemos/t1_preprocess/anat_subject1_nuc_native.mnc.gz ...

I figured out that it waits for an overwrite confirmation ( insering -echo option in the code).

It seems also the cp command behaves strangely in our systems because the cp command do not usually ask overwrite permission.


best regards
Alexis


Dec 9, 2010  11:12 AM | Pierre Bellec
RE: cp or mv commands wait for overwrite confirm
Dear Alexis,

I never experienced that myself, or heard about that issue before. After digging up a bit, I think I got it. You are probably using a CSH terminal, which is the default at the BIC. If you type alias, you'll probably get something like :

cp cp -i
rm rm -i

This means that the sys admin has configured the cp command to ask for a confirmation by default.

A first workaround to this issue is to start a bash shell, which I believe does not have this behavior. A second workaround is to add the following line to your .cshrc (or to a csh script that will change the alias and start matlab, which will not affect your default environment) :

alias cp cp -f
alias rm rm -f

Please let me know if that solved your problem,

Pierre
Jan 14, 2011  01:01 PM | Alexis Machado
RE: cp or mv commands wait for overwrite confirm
thanks a lot
The problem is solved