general-discussion > fMRIstat does not work
Showing 1-5 of 5 posts
Display:
Results per page:
Jan 2, 2011  08:01 AM | Deborah Tang
fMRIstat does not work
So I mistakenly set voxel size to 4 4 4, which means my image resolution has changed, and now fmristat will not read my data. Do I need to change the voxel size back to 3.5 3.5 3.5 to get this fixed, or is there some way to get fmristat to open the files?

Right now I have specified in fmristat that I have 40 slices and 198 frames. Is this correct?

Thanks for your help!! Details on my image resolution are below.
-----------------------------
Before:
mincinfo s_3_4_mri.mnc
file: s_3_4_mri.mnc
image: unsigned short 0 to 4095
image dimensions: time zspace yspace xspace
dimension name length step start
-------------- ------ ---- -----
time 198 2.3 0
zspace 40 3.5 -61.202
yspace 64 -3.5 116.963
xspace 64 -3.5 114.409


---------------
After:
image: signed__ float -10.106241226196289062 to 818.4271240234375
image dimensions: time zspace yspace xspace
dimension name length step start
-------------- ------ ---- -----
time 198 2.3 0
zspace 35 4 -50
yspace 48 4 -112
xspace 40 4 -78

Jan 2, 2011  09:01 AM | Pierre Bellec
RE: fMRIstat does not work
Dear Deborah,

From the results you sent me using mincinfo, it seems that after resampling at a 4 mm isotropic resolution, the datasets now have 35 slices instead of 40. You will have to change the fMRIstat script accordingly. Having said that, this does not explain why fmristat fails to read the images. I made some tests, and there seem to be some problems with EMMA at the BIC, at least with the configuration I use. I have made a couple of modifs to EMMA that solved the problem for me. Try to type the following at the begining of your matlab session :

P = genpath('/data/aces/aces1/pbellec/Matlab/bibliotheque/emma-0.9.7');
addpath(P);

Please let me know if that fixed your issue.

Pierre
Jan 2, 2011  10:01 AM | Deborah Tang
RE: fMRIstat does not work
Hi Pierre,

After changing slices to 35 and adding that path you suggested, I still get the same error. Any other suggestions?

If you want to take a look, the script is located at:
/dagher/dagher3/deb/neuroecon/debscripts/fmristat_runs_saline_one_subj.m

As always, thanks for your help!
Deb
Jan 2, 2011  12:01 PM | Pierre Bellec
RE: fmristat does not work
Hi again,

I had a look at the script. I am not sure why, but fmristat keeps looking for the other version of EMMA. If you use the version of fMRIstat located in my path, you won't have this issue. Add also the following to your script:

P = genpath('/data/aces/aces1/pbellec/Matlab/bibliotheque/fmristat');
addpath(P);

Also I suggest to use

n_trends = [0 1 1];

instead of

n_trends = [3 1 1];

Because the slow time drifts have already been corrected as part of the preprocessing.

Good luck,

Pierre
Jan 2, 2011  12:01 PM | Deborah Tang
RE: fmristat does not work
Hi Pierre,

It works! Thanks so much. :)

Good luck to you too.