general-discussion > no space left on device, matlab is stuck
Showing 1-4 of 4 posts
Display:
Results per page:
Jan 14, 2011  12:01 PM | Alexis Machado
no space left on device, matlab is stuck
Hi Pierre
I lauched the t1_preprocess_demo.m with NIAK 6.4 on your dataset (anat_subject1.mnc). I saved the results on mfip It has worked
After this i tried with my data and i get an error no space left on device .....mv stat cannnot create...
I tried to delete manually the tmp_niak files in the /tmp but it did not work ( i can do noting with the file in the /tmp)
I emptied my trash and it worked a little more longer until the message appeared again.

Now it does not work anymore
More problematic when i open my matlab10a it say there are no space left on the device
and it cannot load java classes. Matlab10a is stuck and i cannot open mfile anymore.

ERROR: Error writing last modification time to bundle archive. (java.io.IOException: No space left on device)
java.io.IOException: No space left on device
at java.io.FileOutputStream.writeBytes(Native Method)
at java.io.FileOutputStream.write(FileOutputStream.java:260)
at sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:202)
at sun.nio.cs.StreamEncoder.implClose(StreamEncoder.java:297)
at sun.nio.cs.StreamEncoder.close(StreamEncoder.java:130)
at java.io.OutputStreamWriter.close(OutputStreamWriter.java:216)
at java.io.BufferedWriter.close(BufferedWriter.java:248)
at org.apache.felix.framework.cache.BundleArchive.setLastModified(BundleArchive.java:533)
at org.apache.felix.framework.BundleImpl.setLastModified(BundleImpl.java:394)
at org.apache.felix.framework.Felix.installBundle(Felix.java:2195)
at org.apache.felix.framework.Felix.installBundle(Felix.java:2026)
at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:130)
at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:108)
at com.mathworks.util.osgi.OSGiManager.installBundles(OSGiManager.java:230)
at com.mathworks.util.osgi.OSGiManager.getBundles(OSGiManager.java:218)
at com.mathworks.util.osgi.OSGiManager.start(OSGiManager.java:99)
at com.mathworks.util.osgi.OSGiManager.getImplementors(OSGiManager.java:142)
at com.mathworks.util.osgi.ClasspathOSGiManager.getImplementors(ClasspathOSGiManager.java:44)
at com.mathworks.widgets.SyntaxHighlightingUtils.registerSyntaxHighlightings(SyntaxHighlightingUtils.java:58)
at com.mathworks.widgets.SyntaxHighlightingUtils.getAllSyntaxHighlightings(SyntaxHighlightingUtils.java:46)
at com.mathworks.widgets.text.EditorPreferences.listenToSyntaxHighlightingPreferences(EditorPreferences.java:165)
at com.mathworks.widgets.STPPrefsManager.(STPPrefsManager.java:79)
at com.mathworks.widgets.STPPrefsManager.getInstance(STPPrefsManager.java:119)
at com.mathworks.widgets.STPPrefsManager.(STPPrefsManager.java:46)
at com.mathworks.widgets.text.MWKit.(MWKit.java:70)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:169)
at com.mathworks.mde.desk.StartupClassLoader.callClassForName(StartupClassLoader.java:316)
at com.mathworks.mde.desk.StartupClassLoader.loadClass(StartupClassLoader.java:294)
at com.mathworks.mde.desk.StartupClassLoader.access$900(StartupClassLoader.java:27)
at com.mathworks.mde.desk.StartupClassLoader$LoadThread.run(StartupClassLoader.java:283)
ERROR: org.apache.felix.framework.cache.BundleArchive: Unable to create archive directory.

Matlab7 seems to work

Any idea ??
Thanks,Best regards
Alexis


Jan 17, 2011  10:01 AM | Pierre Bellec
RE: no space left on device, matlab is stuck
Dear Alexis,

Obviously, one of your disk must be full, which causes all the problems you are experiencing. Try to type :

df -h

in a terminal. This will give you a list of disks and associated mount points, along with the size and free space (in conventional Mbytes Gbytes units, this is what '-h' is for). Then all you have to do is some clean up to free some space ! If the tmp is full and you don't own the files, you can ask the sys admin to restart your system. This will empty the tmp folder.

I hope this helps,

Pierre
Nov 21, 2011  02:11 PM | Alexis Machado
RE: no space left on device, matlab is stuck
Hi Pierre

is there possibilities to attribute the /tmp to another folder where we have more space .

i think it should be changed in the niak_gb_var.m

Best regards
Alexis
Nov 22, 2011  10:11 AM | Christian Dansereau
RE: no space left on device, matlab is stuck
Hello Alexis,

It's effectively possible to change the tmp folder by

editing the gb_niak_tmp variable in commands/misc/niak_gb_vars.m


Regards
Christian