help > Installation Problem
Showing 1-3 of 3 posts
Display:
Results per page:
Apr 5, 2011  02:04 PM | Matt Russell
Installation Problem
Hello BioImage Suite Group,

Recently I've been trying to install BioImage Suite on my computer.  While I can get it working on my Windows 7 partition, I can't seem to get it working on my Ubuntu 10.6 partition (where I actually need it!).  The error it gives me is:

      vtk: error while loading shared libraries: libhistory.so.5: cannot open shared object file: No such file or directory

I thought perhaps this was due to a permissions problem, but even when I log on as root I can't seem to get around this error.  Do you have any suggestions for troubleshooting this?

Thank you,

Matthew Russell
Oct 26, 2012  03:10 AM | Tim Schaefer - Goethe University Frankfurt, Germany
RE: Installation Problem
I know this post is old but I just ran into the same problem and this is the first thing that pops up when you google it, so:

I managed to solve it for my system (OpenSUSE 12.2, 64bit). It seems that BioImage Suit looks for libhistory5 while only libhistory6 is available under this OS. The history lib is essential and some version WILL be installed on your system. The solution is to add a symlink that points programs to the right place. (At least this worked for me in this case, no guarantees here.)

To do this:
1) Find the version that is installed by searching /lib/ (for 32bit)  or /lib64/ for it:
find /lib64/ -name libhist*

This will return something like:
/lib64/libhistory.so.6
/lib64/libhistory.so.6.2

2) Fix it with a symlink:
sudo ln -s /lib64/libhistory.so.6 /lib64/libhistory.so.5

Then run BioImage Suite.
Sep 14, 2017  09:09 AM | Max Nentwich
RE: Installation Problem
Hi, 

I have got a similar error:

vtk: error while loading shared libraries: libhistory.so.5: cannot open shared object file: Error 40

I tried the suggested solution, but that did not help.

Does anyone have an idea on how to solve this?

Thanks,
Max Nentwich