help > Problem with running the code
Showing 1-5 of 5 posts
Results per page:
Jun 13, 2012  05:06 PM | Hengameh Mirzaalian
Problem with running the code
I am trying to apply ShapeWorks on my dataset. The following two command lines work properly.
ShapeWorksGroom ".\\A.preprocess1.params"  isolate  hole_fill  center  auto_crop
ShapeWorksGroom  ".\A.preprocess2.params"  antialias  fastmarching  blur
however, when I run
ShapeWorksRun   ".\\A.correspondence.params"
I receved the following error:
 itk::ExceptionObject (00FCFB2C)
Location: "bool __thiscall itk::ParticleImplicitSurfaceDomain::ApplyCon
straints(class itk::Point &) const"
File: c:\documents and settings\cates\desktop\shapeworks\code\itkparticlesystem\
Line: 121
Description: itk::ERROR: ParticleImplicitSurfaceDomain(01486510): A Point, [46.9
793, -0.00222205, 18.976], was projected outside the given image domain.
Further, ShapeWork works well when I run it over TorusExample dataset, but, when I run it on MickeyExample, it get stuck at particle count: 2 for this command line:
ShapeWorksRun   "".\\MickeyExample\\mickey.group1.correspondence.params"
Would you please guide me how to figure out these problems?
Jun 13, 2012  06:06 PM | Manasi Datar
RE: Problem with running the code
Hi Hengameh

The latest version of ShapeWorks only reads parameter files in the XML format and the Torus and Mickey examples have updated parameter files with them.
The '.params' parameter file format has been dispensed with. If you have source code that works with a '.params' parameter file, i suspect it is an old version and may be susceptible to errors.

i suggest you download the latest version from the NITRC repository here and try the examples again. If the problem persists, I'll be happy to help out :)

Jun 14, 2012  11:06 AM | Hengameh Mirzaalian
RE: Problem with running the code
I will try to build the software using the latest version and cmake...
it seems that the available-online exe files are not the latest versions. It would be really appreciated to provide the updated version file for the users (like me) who are interested to your code :)
Jun 14, 2012  04:06 PM | Manasi Datar
RE: Problem with running the code
Hi Hengameh

I did not realize you were working with the executables directly ! Not many folks use them, and thus they have not been updated in a while.
I will work to get the most current executables up here soon...

In the meanwhile, please let me know if you have trouble building from source.
Aug 1, 2013  12:08 PM | Félix Renard
RE: Problem with running the code

I am new user of ShapeWorks. I try to use the Linux executable. It works for the Torus exemple. It also works on my data for the different preprocessing of ShapeWorksGroom.
Nevertheless when I use the ShapeWorksRun, I receive this following errors:
itk::ExceptionObject (0xf4803610)
Location: "bool itk::ParticleRegionDomain::ApplyConstraints(itk::ParticleRegionDomain::PointType&) const [with unsigned int VDimension = 3u, itk::ParticleRegionDomain::PointType = itk::Point]"
File: /media/Shared/ShapeWorksCode/ShapeWorksNITRC/source/code/ITKParticleSystem/itkParticleRegionDomain.h
Line: 78
Description: itk::ERROR: ParticleImplicitSurfaceDomain(0x936c338): Point [-87.6903, 56.9256, 71.3354] is outside of the specified Domain,  with bounding box [-125.69, 96.9256, 120.335] - [-50.6903, -13.0744, 30.3354]

Will I need to build the source code?
Would you please help me to figure out these problems?

Best regards,