help > failure of mass effect simulation
Showing 1-4 of 4 posts
Results per page:
Dec 11, 2013  01:12 AM | tingting feng
failure of mass effect simulation

I am using  the brain tumor simulation software downloaded from your website.I ran the software on a 64bit ubuntu sytem,with the command as :tumorsim Sim_071.xml.I made a 3D mask ,its size is 256*256*124 and the tumor is located at (165,165) from silce 55 to 65.But during the progress,I encountered the problem showing below:
  Reading VTK mesh...
Reading voxel labels...
Reading anatomical probabilities...
Reading tumor seed image...
Reading diffusion tensor image...
Obtaining MD image...
Scaling DT image...
Reading precomputed texture images...
Mass effect simulation...

Do you have any idea about the cause of the failure of mass effect simulation?
Thanks for your time and wish to receive your reply.
Best regards!
Dec 11, 2013  03:12 PM | Tom Haeck
RE: failure of mass effect simulation
Hey Tina,

I think both a wrong choice of parameters as well as as some library problems can cause this problem.  Maybe it is advisable to run TumorSim on a different platform (e.g. Windows) with the same selection of parameters and input data and to see if it runs there?


Dec 13, 2013  01:12 AM | tingting feng
RE: failure of mass effect simulation
Hi Tom,

Thanks for your help ,I have ran the win32 edition(both 1.0 and 1.1) on the Win32 platform ,but still get the same error.Besides,I have a question about the source image of healthy brain ,I don't know how the software specify the source image because the xml file doesn't specify this .Does there a rule for the directory of the source image?I wonder whether this could be the reason for the failure?

I ran the software as follows:I put the executable file ,the downloaded input folder ,the output folder,the downloaded xml file(modified according to my situation),the downloaded source image (256*256*181) in the same directory F:/scratch/TumorSim.I made a mask with the size 256*256*181,with the seed tumor at(165,165)from slice 70 to slice 90 .The radius of the tumor is 5 pixels.I put the seed.mha in the downloaded input folder.Finally I ran the software in the command window with the command :tumorsim TumorSim.xml.

Best regards!

Dec 13, 2013  08:12 AM | tingting feng
RE: failure of mass effect simulation
Hi Tom,
I ran the software successfully now,the source image I used before was wrong……thanks for your help!
Best regards!