help > Stuck at StatNonParamTest
Showing 1-10 of 10 posts
Results per page:
Jan 28, 2015  02:01 PM | Nils Müller
Stuck at StatNonParamTest

I'm currently planning to do a hippocampal shape analysis. After trying to use 3Dslicer I decided it might be easier to use the command line functions. I managed all steps except I now am stuck using StatNonParamTest. 

For some reason it fails at reading in the files, it seems to confuse the .vtk file with the group information.
This is the command I used:

StatNonParamTestPDM list.txt -surfList -numPerms 1000 -signLevel 0.05 -signSteps 1000 -v

It produced the following output:

/home/memory/nilmul/ShaTut/out/Mesh/Para/groupA_01_hippo_ppSPHARM.vtk 0 1
/home/memory/nilmul/ShaTut/out/Mesh/Para/groupA_02_hippo_ppSPHARM.vtk 0 1
/home/memory/nilmul/ShaTut/out/Mesh/Para/groupB_01_hippo_ppSPHARM.vtk 1 1
/home/memory/nilmul/ShaTut/out/Mesh/Para/groupB_02_hippo_ppSPHARM.vtk 1 1
Skipping unrecognized field # vtk DataFile Version 3.0
Skipping unrecognized field # vtk DataFile Version 3.0
Error reading meshfile: /home/memory/nilmul/ShaTut/out/Mesh/Para/groupA_01_hippo_ppSPHARM.vtk
ITK error: itk::ERROR: SpatialObjectReader(0x184bba0): No groups were found in file /home/memory/nilmul/ShaTut/out/Mesh/Para/groupA_01_hippo_ppSPHARM.vtk

I attached the list.txt file.

I used the latest version of SPHARM-PDM (1.13) and the latest version of StatNonParamTestPDM as well.

Any help would be greatly appreciated!

Best regards,
Attachment: list.txt
Jan 28, 2015  04:01 PM | Martin Styner
RE: Stuck at StatNonParamTest
Hi Nils
StatNonParamTestPDM is an older version of our statistical analysis that is currently no longer supported (I did recompile it just a while ago, which is the version you are using, as requested by one of the SPHARM users, but in general we advocate the use of its replacement, shapeAnalysisMANCOVA).

If you want to use StatNonParamTestPDM then you have to first convert the surfaces to an older surface format use by pre v1.0 versions. At that point, SPHARM employed the ITK-based meta surface format, currently we are supporting the more widely employed vtk format.

So, you need to first convert your vtk surface to meta surfaces and then you feed those meta surfaces to StatNonParamtestPDM. This can be done with the VTK2Meta tool that is distributed with SPHARM.

Hope this helps
Jan 30, 2015  04:01 PM | Nils Müller
RE: Stuck at StatNonParamTest
Dear Martin,

Thanks for the extremly quick reply! I would prefer to use shapeAnalysisMANCOVA and have been trying the last two days to get the version I found on your github to compile but so far that doesn't work out. Not quite sure where the compilation goes wrong but it might be that the versions of vtk,itk or Qt I have cause some compatibility issues.

Could you tell me what the minimal set of toolboxes (vtk,itk,GenerateCLP,Qt,...) to get at least the commandline of shapeAnalysisMANCOVA to work and which source code best to use (the one from the publication or is there an updated one? Or even a compiled version?).

Otherwise I would probably use the StatNonParamTestPDM and convert everything to meta surfaces, not sure whether that would have any disadvantages in terms of the analysis part. 

Jan 30, 2015  04:01 PM | Beatriz Paniagua
RE: Stuck at StatNonParamTest
Hi Nils,

Are you trying to compile the whole repository or just shapeAnalysisMANCOVA? Some of our users have reported problems compiling shapeAnalysisMANCOVA_Wizard because of Qt, but it is the first time that I hear about shapeAnalysisMANCOVA. Please let me know, and I will look into it.

Thank you,
Jan 30, 2015  04:01 PM | Nils Müller
RE: Stuck at StatNonParamTest
Hi Beatriz, 

I'm amazed by your response speed as well :).

I actually tried both, after I realized the problems with Qt I thought it might be easier to try to compile just the "shapeAnalysisMANCOVA" subdirectory. But even that seems to not work out, I managed to run ccmake but if fails when I try to build it using "gmake" 

I attached the error message, my best guess that there is an incompatibilty between the VTK version I have installed (6.1) and the Version of shapeAnalysisMancova. But thats an uneducated guess.

Attachment: Gmake_error.txt
Jan 30, 2015  05:01 PM | Martin Styner
RE: Stuck at StatNonParamTest
That may be the case, it certainly looks like a VTK issue. I think it's best to use VTK 5.10 version. 
Jan 30, 2015  05:01 PM | Beatriz Paniagua
RE: Stuck at StatNonParamTest
Hi Nils,

It seems to me ccmake is not able to find VTK at all.
You can always specify use_SYSTEM_VTK indicating your vtk folder when building the whole project and set build_shapeanalysismancovawizar and build_statnonparamesh to off.

Is this the way you are compiling?

Jan 30, 2015  05:01 PM | Nils Müller
RE: Stuck at StatNonParamTest
No I'm not specifying those. Where exactly would I do that? 

Before getting those error messages I got other ones saying it couldn't find the functions its now referring to. Then I installed VTK 6.1 and got those messages so I presume it can find them now. 

I'm now trying to install VTK 5.1 and see whether that will work.
Jan 31, 2015  02:01 PM | Nils Müller
RE: Stuck at StatNonParamTest
There indeed seemed to have been a problem with VTK (though I'm not sure it was the installation or the version I used). 

I recompiled ITK (4.7) and VTK (5.1) and could succesfully compile shapeAnalysisMANCOVA. It seems to run now!

Thanks a lot Martin and and Beatriz!

Feb 1, 2015  04:02 PM | Nils Müller
Now stuck at ShapeANALYSIS
After I managed to install shapeAnalysisMANCOVA, I have problems in executing the command. I'm trying it out on the tutorial data. 

I tried using minimal syntax:
shapeAnalysisMANCOVA -n 1000 list.txt

--------------------- The output it produces -----------------

input file specified: list.txt
filename: list.txt numIndependent: 0
Num Subjects: 4

data in group_type 0 has been relabeled: -1 --> group A = -1 ; 1 --> group B = 1
#(A)= 2; #(B)= 2
/home/memory/nilmul/ShaTut/out/Mesh/Para/groupB_01_hippo_ppSPHARM_ellalign.vtk -1 1
/home/memory/nilmul/ShaTut/out/Mesh/Para/groupB_02_hippo_ppSPHARM_ellalign.vtk -1 1
/home/memory/nilmul/ShaTut/out/Mesh/Para/groupA_01_hippo_ppSPHARM_ellalign.vtk 1 1
/home/memory/nilmul/ShaTut/out/Mesh/Para/groupA_02_hippo_ppSPHARM_ellalign.vtk 1 1
reading Mesh /home/memory/nilmul/ShaTut/out/Mesh/Para/groupB_01_hippo_ppSPHARM_ellalign.vtk - .vtk
reading Mesh /home/memory/nilmul/ShaTut/out/Mesh/Para/groupB_02_hippo_ppSPHARM_ellalign.vtk - .vtk
reading Mesh /home/memory/nilmul/ShaTut/out/Mesh/Para/groupA_01_hippo_ppSPHARM_ellalign.vtk - .vtk
reading Mesh /home/memory/nilmul/ShaTut/out/Mesh/Para/groupA_02_hippo_ppSPHARM_ellalign.vtk - .vtk
No statistic type selected, defaulting to Hotelling.
Now running nonparametric tests:
Performing MANCOVA permutation testing.
Using 1000 permutations.
Completed MANCOVA permutation testing.
fdr thresh (MANCOVA) is = 0
Runtime was 0 minute(s) and 7 second(s).
terminate called after throwing an instance of 'std::out_of_range'
what(): basic_string::erase


It produces some of the output files:  
Is it normal that  only one of the meshes is in .vtk format but the other ones in .meta?

Since it crashes I'm not quite sure whether I can the results now. Any ideas where the crash could come from?

Thanks again! 
Attachment: list.txt