open-discussion > DTIPrep command line installation
Showing 1-25 of 25 posts
Display:
Results per page:
Sep 19, 2016  09:09 AM | Tanmay Nath
DTIPrep command line installation
Hi,

Can anyone point me to the command line installation of DTIPrep? I was using this
svn checkout https://www.nitrc.org/svn/dtiprep/trunk DTIPrep

but it gives me following output.

svn: E175013: Unable to connect to a repository at URL 'https://www.nitrc.org/svn/dtiprep/trunk'
svn: E175013: Access to 'https://www.nitrc.org/svn/dtiprep/trunk' forbidden 

I do have the nitrc account, but I am not sure how to seek permission to install DTIPrep.

Thanks
Sep 19, 2016  11:09 AM | Martin Styner
RE: DTIPrep command line installation
The svn repository has been replaced by a git repository. If you click on the "source code" link in the navigation menu to the left. It will take you to the git repo on github. You can then get the code via 
git clone https://github.com/NIRALUser/DTIPrep.git

Hope this helps
Martin
Sep 19, 2016  11:09 AM | Tanmay Nath
RE: DTIPrep command line installation
Hi Martin
Thank you . I was able to download the DTIPrep. I used the following steps to install it, but now i do not know how to start the DTIPrep. Also, strangely, the make process was very quick. I wonder if i made any mistake while installing DTIPrep.

After these steps, I have the list of directories in my current working directory. Please find it in the attachment.
Can you please explain me how to go ahead with this?
Sep 19, 2016  12:09 PM | Juan Prieto - NIRAL
RE: DTIPrep command line installation
Hi Tanmay, 

Could you please visit the github page https://github.com/NIRALUser/DTIPrep and use the github repository address to checkout DTIPrep?

Best, 

Juan
Sep 19, 2016  12:09 PM | Juan Prieto - NIRAL
RE: DTIPrep command line installation
Did you execute the make command after configuration? 

The build steps should look something like this. 

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. ccmake ../DTIPrep
4. make

Best, 

Juan
Sep 19, 2016  01:09 PM | Tanmay Nath
RE: DTIPrep command line installation
Hi,

Thanks Juan it works. The difference was in the step 4. I was doing ccmake rather than make.

But now when i am running the command line, it opens the GUI. I do not want to use GUI. I need to use it from command line.

./DTIPrep_build/bin/DTIPrep.app/Contents/MacOS/DTIPrep -w sub5621/data/01+dti_64dir_3x3x3/sub5621_a.nhdr -d -f working_projects/sub5621/sub5621_QC/

Any idea how to make it run via command line?
Sep 20, 2016  07:09 AM | Tanmay Nath
RE: DTIPrep command line installation
Any help?
Sep 20, 2016  08:09 AM | Juan Prieto - NIRAL
RE: DTIPrep command line installation
When you type 'DTIPrep --help' you can get the full description of the options for this program. 

The flag you want to use is '-c' when you don't want to use the graphical user interface. 

Something like, 

./DTIPrep_build/bin/DTIPrep.app/Contents/MacOS/DTIPrep -w sub5621/data/01+dti_64dir_3x3x3/sub5621_a.nhdr -d -f working_projects/sub5621/sub5621_QC/ -c

Best, 

Juan
Sep 20, 2016  08:09 AM | Tanmay Nath
RE: DTIPrep command line installation
Thanks.It worked :)
Aug 8, 2017  09:08 AM | Cyril Pernet
RE: DTIPrep command line installation
Dear Juan,

I followed the instructions below but I got an error message related to Qt
Did you execute the make command after configuration? 

The build steps should look something like this. 

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. ccmake ../DTIPrep
4. make

I'm running Ubuntu Xenial and have intalled Qt5 Qt4 following the instruction here
https://wiki.qt.io/Install_Qt_5_on_Ubuntu
error message seems to be that I need at least qt4.6  ?? 
CMake Error at
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148
(message):
Could NOT find Qt4 (missing: QT_RCC_EXECUTABLE) (found suitable version
"4.8.7", minimum required is "4.6")
Call Stack (most recent call first):
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388
(_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.5/Modules/FindQt4.cmake:1333
(FIND_PACKAGE_HANDLE_STANDARD_ARGS)
Common.cmake:38 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:29 (include)

Any ideee how to make it work ?? 

thx
cyril

Sep 8, 2017  10:09 AM | Amanda Szymanski
RE: DTIPrep command line installation
I'm having a similar issue as Cyril:

CMake Error at /usr/local/Cellar/cmake/3.9.2/share/cmake/Modules/FindQt4.cmake:1318 (message):
Found unsuitable Qt version "" from NOTFOUND, this code requires Qt 4.x
Call Stack (most recent call first):
Common.cmake:35 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:28 (include)

I have Qt5 installed. I've tried installing Qt4 & directing ccmake to use that instead, but it still wouldn't work. Any suggestions?

Originally posted by Cyril Pernet:
Dear Juan,

I followed the instructions below but I got an error message related to Qt
Did you execute the make command after configuration? 

The build steps should look something like this. 

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. ccmake ../DTIPrep
4. make

I'm running Ubuntu Xenial and have intalled Qt5 Qt4 following the instruction here
https://wiki.qt.io/Install_Qt_5_on_Ubuntu
error message seems to be that I need at least qt4.6  ?? 
CMake Error at
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148
(message):
Could NOT find Qt4 (missing: QT_RCC_EXECUTABLE) (found suitable version
"4.8.7", minimum required is "4.6")
Call Stack (most recent call first):
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388
(_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.5/Modules/FindQt4.cmake:1333
(FIND_PACKAGE_HANDLE_STANDARD_ARGS)
Common.cmake:38 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:29 (include)

Any ideee how to make it work ?? 

thx
cyril

Mar 5, 2018  09:03 AM | Huan Yang
RE: DTIPrep command line installation
Why after I tried the command "ccmake", it always said that "command not found"?  Thank you so much if you know the answer.
Originally posted by Juan Prieto:
Did you execute the make command after configuration? 

The build steps should look something like this. 

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. ccmake ../DTIPrep
4. make

Best, 

Juan
Mar 5, 2018  09:03 AM | Martin Styner
RE: DTIPrep command line installation
You need to first install cmake (ccmake is part of cmake)

Martin
Mar 6, 2018  09:03 AM | Huan Yang
RE: DTIPrep command line installation
Thank you so much for your quick reply, Martin. 
I have install the cmake, but after I run the recommend " ccmake ../DTIPrep", it opened the CMake interface, said "empty cache".
 
Could you please tell me why this happen? I followed the instruction before, and the first two steps seems run correctly.
Thank you so much for you help.

Huan
Mar 6, 2018  01:03 PM | Juan Prieto - NIRAL
RE: DTIPrep command line installation
Can you run the following commands inside the DTIPrep-build directory?

mkdir bin; 
cmake ../DTIPrep


The command 'ccmake' brings up the interface of cmake, but if you run 'cmake' only, it will configure the project. 

Best,
Mar 13, 2018  03:03 PM | Ryan H - UCLA
RE: DTIPrep command line installation
Hi, 

Of the 4 following steps, I've successfully executed the first 3: 

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. cmake ../DTIPrep
4. make


However, when I enter 'make' into the command line, I encounter the following errors:


(venv) [rhyon@n2236 DTIPrep-build]$ make
Scanning dependencies of target OpenCV
[ 1%] Creating directories for 'OpenCV'
[ 2%] Performing download step (git clone) for 'OpenCV'
error: unknown option 'config'
usage: git clone [options] [--] []

-v, --verbose be more verbose
-q, --quiet be more quiet
--progress force progress reporting
-n, --no-checkout don't create a checkout
--bare create a bare repository
--mirror create a mirror repository (implies bare)
-l, --local to clone from a local repository
--no-hardlinks don't use local hardlinks, always copy
-s, --shared setup as shared repository
--recursive initialize submodules in the clone
--template path the template repository
--reference reference repository
-o, --origin
use instead of 'origin' to track upstream
-b, --branch
checkout instead of the remote's HEAD
-u, --upload-pack
path to git-upload-pack on the remote
--depth create a shallow clone of that depth
error: unknown option 'config'
usage: git clone [options] [--] []
-v, --verbose be more verbose
-q, --quiet be more quiet
--progress force progress reporting
-n, --no-checkout don't create a checkout
--bare create a bare repository
--mirror create a mirror repository (implies bare)
-l, --local to clone from a local repository
--no-hardlinks don't use local hardlinks, always copy
-s, --shared setup as shared repository
--recursive initialize submodules in the clone
--template path the template repository
--reference reference repository
-o, --origin
use instead of 'origin' to track upstream
-b, --branch
checkout instead of the remote's HEAD
-u, --upload-pack
path to git-upload-pack on the remote
--depth create a shallow clone of that depth
error: unknown option 'config'
usage: git clone [options] [--] []
-v, --verbose be more verbose
-q, --quiet be more quiet
--progress force progress reporting
-n, --no-checkout don't create a checkout
--bare create a bare repository
--mirror create a mirror repository (implies bare)
-l, --local to clone from a local repository
--no-hardlinks don't use local hardlinks, always copy
-s, --shared setup as shared repository
--recursive initialize submodules in the clone
--template path the template repository
--reference reference repository
-o, --origin
use instead of 'origin' to track upstream
-b, --branch
checkout instead of the remote's HEAD
-u, --upload-pack
path to git-upload-pack on the remote
--depth create a shallow clone of that depth
-- Had to git clone more than once:
3 times.
CMake Error at /u/home/r/rhyon/DTIPrep-build/OpenCV-prefix/tmp/OpenCV-gitclone.cmake:66 (message):
Failed to clone repository: 'git://github.com/BRAINSia/opencv.git'
make[2]: *** [OpenCV-prefix/src/OpenCV-stamp/OpenCV-download] Error 1
make[1]: *** [CMakeFiles/OpenCV.dir/all] Error 2
make: *** [all] Error 2


Do you know what could be going wrong? Thank you, much appreciated!
Mar 15, 2018  02:03 PM | Juan Prieto - NIRAL
RE: DTIPrep command line installation
Could you please let me know your git version? 
If you have an older version, that may be the cause of this error. The minimum version should be 2.2.1, older version should work just fine. 

Best,
Apr 22, 2018  05:04 AM | Anna Kautto - University of Turku
RE: DTIPrep command line installation
I also have a problem with Qt version. I have 5.6.2 and I get error "Found unsuitable Qt version "5.6.2" from /anaconda3/bin/qmake, this code
requires Qt 4.x" Should I try installing older version of Qt? Did someone already solve this issue?

Anna
Originally posted by Amanda Szymanski:
I'm having a similar issue as Cyril:

CMake Error at /usr/local/Cellar/cmake/3.9.2/share/cmake/Modules/FindQt4.cmake:1318 (message):
Found unsuitable Qt version "" from NOTFOUND, this code requires Qt 4.x
Call Stack (most recent call first):
Common.cmake:35 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:28 (include)

I have Qt5 installed. I've tried installing Qt4 & directing ccmake to use that instead, but it still wouldn't work. Any suggestions?

Originally posted by Cyril Pernet:
Dear Juan,

I followed the instructions below but I got an error message related to Qt
Did you execute the make command after configuration? 

The build steps should look something like this. 

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. ccmake ../DTIPrep
4. make

I'm running Ubuntu Xenial and have intalled Qt5 Qt4 following the instruction here
https://wiki.qt.io/Install_Qt_5_on_Ubuntu
error message seems to be that I need at least qt4.6  ?? 
CMake Error at
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148
(message):
Could NOT find Qt4 (missing: QT_RCC_EXECUTABLE) (found suitable version
"4.8.7", minimum required is "4.6")
Call Stack (most recent call first):
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388
(_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.5/Modules/FindQt4.cmake:1333
(FIND_PACKAGE_HANDLE_STANDARD_ARGS)
Common.cmake:38 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:29 (include)

Any ideee how to make it work ?? 

thx
cyril

Jun 20, 2018  07:06 PM | XIAO YANG
RE: DTIPrep command line installation
Dear Experts and DTIPrep users,

I am trying to do the build steps following:

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. ccmake ../DTIPrep
4. make

I had a similar problem. When I did run: cmake ../DTIPrep

CMake Error at /usr/local/Cellar/cmake/3.11.4/share/cmake/Modules/FindQt4.cmake:1321 (message):
Found unsuitable Qt version "5.6.2" from /anaconda3/bin/qmake, this code
requires Qt 4.x
Call Stack (most recent call first):
Common.cmake:35 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:28 (include)

Aftet I installed qt4 /usr/local/Cellar/qt@4/4.8.7_5: 2,963 files, 86.1MB. it still didn't work.

Any help and suggestion would be appreciated.

Best,

Xiao

Originally posted by Anna Kautto:
I also have a problem with Qt version. I have 5.6.2 and I get error "Found unsuitable Qt version "5.6.2" from /anaconda3/bin/qmake, this code
requires Qt 4.x" Should I try installing older version of Qt? Did someone already solve this issue?

Anna
Originally posted by Amanda Szymanski:
I'm having a similar issue as Cyril:

CMake Error at /usr/local/Cellar/cmake/3.9.2/share/cmake/Modules/FindQt4.cmake:1318 (message):
Found unsuitable Qt version "" from NOTFOUND, this code requires Qt 4.x
Call Stack (most recent call first):
Common.cmake:35 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:28 (include)

I have Qt5 installed. I've tried installing Qt4 & directing ccmake to use that instead, but it still wouldn't work. Any suggestions?

Originally posted by Cyril Pernet:
Dear Juan,

I followed the instructions below but I got an error message related to Qt
Did you execute the make command after configuration? 

The build steps should look something like this. 

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. ccmake ../DTIPrep
4. make

I'm running Ubuntu Xenial and have intalled Qt5 Qt4 following the instruction here
https://wiki.qt.io/Install_Qt_5_on_Ubuntu
error message seems to be that I need at least qt4.6  ?? 
CMake Error at
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148
(message):
Could NOT find Qt4 (missing: QT_RCC_EXECUTABLE) (found suitable version
"4.8.7", minimum required is "4.6")
Call Stack (most recent call first):
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388
(_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.5/Modules/FindQt4.cmake:1333
(FIND_PACKAGE_HANDLE_STANDARD_ARGS)
Common.cmake:38 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:29 (include)

Any ideee how to make it work ?? 

thx
cyril

Jun 29, 2018  07:06 AM | Kelli Dominick - Cincinnati Children's Hospital Medical Center
RE: DTIPrep command line installation
Did anyone get a solution to this?
Originally posted by XIAO YANG:
Dear Experts and DTIPrep users,

I am trying to do the build steps following:

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. ccmake ../DTIPrep
4. make

I had a similar problem. When I did run: cmake ../DTIPrep

CMake Error at /usr/local/Cellar/cmake/3.11.4/share/cmake/Modules/FindQt4.cmake:1321 (message):
Found unsuitable Qt version "5.6.2" from /anaconda3/bin/qmake, this code
requires Qt 4.x
Call Stack (most recent call first):
Common.cmake:35 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:28 (include)

Aftet I installed qt4 /usr/local/Cellar/qt@4/4.8.7_5: 2,963 files, 86.1MB. it still didn't work.

Any help and suggestion would be appreciated.

Best,

Xiao

Originally posted by Anna Kautto:
I also have a problem with Qt version. I have 5.6.2 and I get error "Found unsuitable Qt version "5.6.2" from /anaconda3/bin/qmake, this code
requires Qt 4.x" Should I try installing older version of Qt? Did someone already solve this issue?

Anna
Originally posted by Amanda Szymanski:
I'm having a similar issue as Cyril:

CMake Error at /usr/local/Cellar/cmake/3.9.2/share/cmake/Modules/FindQt4.cmake:1318 (message):
Found unsuitable Qt version "" from NOTFOUND, this code requires Qt 4.x
Call Stack (most recent call first):
Common.cmake:35 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:28 (include)

I have Qt5 installed. I've tried installing Qt4 & directing ccmake to use that instead, but it still wouldn't work. Any suggestions?

Originally posted by Cyril Pernet:
Dear Juan,

I followed the instructions below but I got an error message related to Qt
Did you execute the make command after configuration? 

The build steps should look something like this. 

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. ccmake ../DTIPrep
4. make

I'm running Ubuntu Xenial and have intalled Qt5 Qt4 following the instruction here
https://wiki.qt.io/Install_Qt_5_on_Ubuntu
error message seems to be that I need at least qt4.6  ?? 
CMake Error at
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148
(message):
Could NOT find Qt4 (missing: QT_RCC_EXECUTABLE) (found suitable version
"4.8.7", minimum required is "4.6")
Call Stack (most recent call first):
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388
(_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.5/Modules/FindQt4.cmake:1333
(FIND_PACKAGE_HANDLE_STANDARD_ARGS)
Common.cmake:38 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:29 (include)

Any ideee how to make it work ?? 

thx
cyril

Jun 29, 2018  08:06 AM | Martin Styner
RE: DTIPrep command line installation
Juan Prieto would probably be more appropriate to answer this, but here a bit of guidance
1. DTIPrep needs QT 4 (like you realized)
2. After you installed QT 4, and you rerun ccmake, does it find the correct version and sets the paths correctly for QT?

Did you start the configuration and compilation from scratch after the installation of QT4, or did you try to continue on the previous compilation that did not succeed with Qt5? If not, just try to compile from scratch.

Martin
Originally posted by Kelli Dominick:
Did anyone get a solution to this?
Originally posted by XIAO YANG:
Dear Experts and DTIPrep users,

I am trying to do the build steps following:

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. ccmake ../DTIPrep
4. make

I had a similar problem. When I did run: cmake ../DTIPrep

CMake Error at /usr/local/Cellar/cmake/3.11.4/share/cmake/Modules/FindQt4.cmake:1321 (message):
Found unsuitable Qt version "5.6.2" from /anaconda3/bin/qmake, this code
requires Qt 4.x
Call Stack (most recent call first):
Common.cmake:35 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:28 (include)

Aftet I installed qt4 /usr/local/Cellar/qt@4/4.8.7_5: 2,963 files, 86.1MB. it still didn't work.

Any help and suggestion would be appreciated.

Best,

Xiao

Originally posted by Anna Kautto:
I also have a problem with Qt version. I have 5.6.2 and I get error "Found unsuitable Qt version "5.6.2" from /anaconda3/bin/qmake, this code
requires Qt 4.x" Should I try installing older version of Qt? Did someone already solve this issue?

Anna
Originally posted by Amanda Szymanski:
I'm having a similar issue as Cyril:

CMake Error at /usr/local/Cellar/cmake/3.9.2/share/cmake/Modules/FindQt4.cmake:1318 (message):
Found unsuitable Qt version "" from NOTFOUND, this code requires Qt 4.x
Call Stack (most recent call first):
Common.cmake:35 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:28 (include)

I have Qt5 installed. I've tried installing Qt4 & directing ccmake to use that instead, but it still wouldn't work. Any suggestions?

Originally posted by Cyril Pernet:
Dear Juan,

I followed the instructions below but I got an error message related to Qt
Did you execute the make command after configuration? 

The build steps should look something like this. 

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. ccmake ../DTIPrep
4. make

I'm running Ubuntu Xenial and have intalled Qt5 Qt4 following the instruction here
https://wiki.qt.io/Install_Qt_5_on_Ubuntu
error message seems to be that I need at least qt4.6  ?? 
CMake Error at
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148
(message):
Could NOT find Qt4 (missing: QT_RCC_EXECUTABLE) (found suitable version
"4.8.7", minimum required is "4.6")
Call Stack (most recent call first):
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388
(_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.5/Modules/FindQt4.cmake:1333
(FIND_PACKAGE_HANDLE_STANDARD_ARGS)
Common.cmake:38 (find_package)
SuperBuild.cmake:20 (include)
CMakeLists.txt:29 (include)

Any ideee how to make it work ?? 

thx
cyril

Sep 3, 2018  03:09 AM | Abhineet Ojha
RE: DTIPrep command line installation
Originally posted by Juan Prieto:
Did you execute the make command after configuration? 

The build steps should look something like this. 

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. ccmake ../DTIPrep
4. make

Best, 

Juan

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. ccmake ../DTIPrep
4. make

I am able to execute first two commands without any error but in third command it is giving this error(mentioned in red colour). Please, look at it and provide appropriate solution


abhineet@abhineet-SVE15118FNB:~/DTIPrep-build$ sudo cmake ../DTIPrep
-- Found Qt4: /usr/bin/qmake (found suitable version "4.8.7", minimum required is "4.6")
-- Performing Test C_HAS_WARNING-Wformat=2
-- Performing Test C_HAS_WARNING-Wformat=2 - Success
-- Performing Test CXX_HAS_WARNING-Wformat=2
-- Performing Test CXX_HAS_WARNING-Wformat=2 - Success
-- Found Qt4: /usr/bin/qmake (found version "4.8.7")
-- SuperBuild - DTIPrepTools => Requires VTK, DCMTK, ITKv4, SlicerExecutionModel, DTIProcess, niral_utilities, BRAINSTools,
-- SuperBuild - VTK[OK]
-- SuperBuild - DCMTK[OK]
-- SuperBuild - DCMTK => Requires TIFF, JPEG, zlib,
-- SuperBuild - TIFF[OK]
-- SuperBuild - TIFF => Requires zlib, JPEG,
-- SuperBuild - zlib[OK]
-- SuperBuild - JPEG[OK]
-- SuperBuild - TIFF[OK]
-- SuperBuild - DCMTK[OK]
-- SuperBuild - ITKv4 => Requires VTK[INCLUDED], DCMTK[INCLUDED], TIFF[INCLUDED], JPEG[INCLUDED], zlib[INCLUDED],
-- SuperBuild - ITKv4[OK]
-- SuperBuild - SlicerExecutionModel => Requires ITKv4[INCLUDED],
-- SuperBuild - SlicerExecutionModel[OK]
CMake Error at SuperBuild/External_DTIProcess.cmake:36 (if):
if given arguments:

"DEFINED" "DTIProcess_DIR" "AND" "NOT" "EXISTS" "AND" "NOT" "EXISTS"
Unknown arguments specified
Call Stack (most recent call first):
CMake/SlicerMacroCheckExternalProjectDependency.cmake:69 (include)
SuperBuild.cmake:288 (SlicerMacroCheckExternalProjectDependency)
CMakeLists.txt:28 (include)
-- Configuring incomplete, errors occurred!
See also "/home/abhineet/DTIPrep-build/CMakeFiles/CMakeOutput.log".
See also "/home/abhineet/DTIPrep-build/CMakeFiles/CMakeError.log".
Sep 4, 2018  08:09 AM | Juan Prieto - NIRAL
RE: DTIPrep command line installation
The following commit fixes finding the DTIProcess package https://github.com/NIRALUser/DTIPrep/com...
The following commit fixes building the TIFF library with ZLIB support https://github.com/NIRALUser/DTIPrep/com...


Please remove the current version of the source code and try the commands again.

Best,
Sep 5, 2018  08:09 AM | Abhineet Ojha
RE: DTIPrep command line installation
Originally posted by Juan Prieto:
The following commit fixes finding the DTIProcess package https://github.com/NIRALUser/DTIPrep/com...
The following commit fixes building the TIFF library with ZLIB support https://github.com/NIRALUser/DTIPrep/com...


Please remove the current version of the source code and try the commands again.

Best,
Dear Sir,
First of all, thanks for updating the program. I am able to compile DTIPrep.
Sorry to bother you again.
I am getting an error (in red colour font)while running in Performing configure step for 'niral_utilities' part while running make command.
I had try to look for it online but unable to find any solution.
Please provide your insight on how to solve this error.
I am also attaching .png file showing my ccmake option for DTIPrep.


abhineet@abhineet-SVE15118FNB:~/DTIPrep-build$ cmake ../DTIPrep
-- Found Qt4: /usr/bin/qmake (found suitable version "4.8.7", minimum required is "4.6")
-- Performing Test C_HAS_WARNING-Wformat=2
-- Performing Test C_HAS_WARNING-Wformat=2 - Success
-- Performing Test CXX_HAS_WARNING-Wformat=2
-- Performing Test CXX_HAS_WARNING-Wformat=2 - Success
-- Found Qt4: /usr/bin/qmake (found version "4.8.7")
-- SuperBuild - DTIPrepTools => Requires VTK, DCMTK, ITKv4, SlicerExecutionModel, DTIProcess, niral_utilities, BRAINSTools,
-- SuperBuild - VTK[OK]
-- SuperBuild - DCMTK[OK]
-- SuperBuild - DCMTK => Requires TIFF, JPEG, zlib,
-- SuperBuild - TIFF[OK]
-- SuperBuild - TIFF => Requires zlib, JPEG,
-- SuperBuild - zlib[OK]
-- SuperBuild - JPEG[OK]
-- SuperBuild - TIFF[OK]
-- SuperBuild - DCMTK[OK]
-- SuperBuild - ITKv4 => Requires VTK[INCLUDED], DCMTK[INCLUDED], TIFF[INCLUDED], JPEG[INCLUDED], zlib[INCLUDED],
-- SuperBuild - ITKv4[OK]
-- SuperBuild - SlicerExecutionModel => Requires ITKv4[INCLUDED],
-- SuperBuild - SlicerExecutionModel[OK]
-- SuperBuild - DTIProcess => Requires ITKv4[INCLUDED], VTK[INCLUDED], SlicerExecutionModel[INCLUDED],
-- SuperBuild - DTIProcess[OK]
-- SuperBuild - niral_utilities => Requires ITKv4[INCLUDED], VTK[INCLUDED], SlicerExecutionModel[INCLUDED],
-- SuperBuild - niral_utilities[OK]
-- SuperBuild - BRAINSTools => Requires ITKv4[INCLUDED], SlicerExecutionModel[INCLUDED], VTK[INCLUDED], DCMTK[INCLUDED], teem, OpenCV, zlib[INCLUDED],
-- SuperBuild - teem => Requires zlib[INCLUDED],
-- SuperBuild - teem[OK]
-- SuperBuild - OpenCV[OK]
-- SuperBuild - BRAINSTools[OK]
-- SuperBuild - BRAINSTools => Requires ITKv4[INCLUDED], SlicerExecutionModel[INCLUDED], VTK[INCLUDED], DCMTK[INCLUDED], teem[INCLUDED], OpenCV[INCLUDED], zlib[INCLUDED], TIFF[INCLUDED], JPEG[INCLUDED],
-- SuperBuild - BRAINSTools[OK]
-- SuperBuild - DTIPrepTools[OK]
-- Configuring done
-- Generating done
-- Build files have been written to: /home/abhineet/DTIPrep-build

abhineet@abhineet-SVE15118FNB:~/DTIPrep-build$ sudo make
[ 8%] Built target OpenCV
[ 16%] Built target zlib
[ 24%] Built target teem
[ 32%] Built target VTK
[ 39%] Built target JPEG
[ 47%] Built target TIFF
[ 55%] Built target DCMTK
[ 63%] Built target ITKv4
[ 70%] Built target SlicerExecutionModel
[ 78%] Built target DTIProcess
[ 79%] Performing configure step for 'niral_utilities'
-- Configuring executable: ImageMath
-- Configuring executable: convertITKformats
-- Configuring executable: convertITKformats4D
-- Configuring executable: convertTextToImage
-- Configuring done
CMake Error: INSTALL(EXPORT) given unknown export "niral_utilitiesTargets"
-- Generating done
-- Build files have been written to: /home/abhineet/DTIPrep-build/niral_utilities-build
CMakeFiles/niral_utilities.dir/build.make:109: recipe for target 'niral_utilities-prefix/src/niral_utilities-stamp/niral_utilities-configure' failed
make[2]: *** [niral_utilities-prefix/src/niral_utilities-stamp/niral_utilities-configure] Error 1
CMakeFiles/Makefile2:697: recipe for target 'CMakeFiles/niral_utilities.dir/all' failed
make[1]: *** [CMakeFiles/niral_utilities.dir/all] Error 2
Makefile:94: recipe for target 'all' failed
make: *** [all] Error 2
Attachment: ccmake DTIPrep.png
Sep 10, 2018  06:09 AM | Juan Prieto - NIRAL
RE: DTIPrep command line installation
Is this issue resolved with the latest updates?