open-discussion > Some images will not load in BIS web
Showing 1-13 of 13 posts
Display:
Results per page:
Nov 21, 2018  03:11 AM | Larry Olson - Emory University
Some images will not load in BIS web
Certain images will not load into BIS web (both command line and desktop). I attached an example.
The good news is that it will load if I first open it in another program (eg BrainSuite), then save it out as a new file or overwrite the original, but that should not have to be the case.
Attachment: T1.nii
Nov 21, 2018  08:11 AM | Xenophon Papademetris
Some images will notload in BIS web
Thanks. We'll take a look. Where are these images from? My hunch is that the headers are not complete and we are being a little to fussy about that right now.
Nov 21, 2018  11:11 AM | Larry Olson - Emory University
RE: Some images will notload in BIS web
Originally posted by Xenophon Papademetris:
Thanks. We'll take a look. Where are these images from? My hunch is that the headers are not complete and we are being a little to fussy about that right now.
The images originated in as a dicom download into a single folder from GE PACS. (never had trouble with this before, and conversion of the same dicoms to Analyze format using ImageJ gives no problem).

They were then converted to .nii using Chris Rorden's dcm2nii (which also has never given trouble). Other programs like BrainSuite or MRIcron read them in just fine.

Thanks for looking. The new BIS Web is fabulous. I am definitely taking advantage of both the Web GUI and command line. But for now I am hoping to find a work around I can use to access the images from the BIS web command line which I use in a postprocessing pipeline. This is a real holdup for me. Interestingly, not all images acquired and converted in the same exact way give this trouble.

BTW- any chance there could be an image processing option to invert the image intensities? I have not been satisfied with SPM for this.
Nov 21, 2018  11:11 AM | Larry Olson - Emory University
RE: Some images will notload in BIS web
Oops the T1.nii I sent you had already been "corrected" by opening in BrainSuite and resaving.

Here I attach the problematic uncorrected original version (from the dicom2nii conversion of the dicom folder). It does not open in BIS.
Sorry about the error
Attachment: T1a.nii
Nov 23, 2018  01:11 PM | Xenophon Papademetris
RE: Some imageswill notload in BIS web
What machine was the conversion done? (i.e. the T1.nii file created). It looks byte-swapped to me which explains why saving it fixes it.
Nov 23, 2018  01:11 PM | Larry Olson - Emory University
RE: Some imageswill notload in BIS web
Originally posted by Xenophon Papademetris:
What machine was the conversion done? (i.e. the T1.nii file created). It looks byte-swapped to me which explains why saving it fixes it.
As I mentioned before, the T1.nii file loads fine. My error- it was already saved and fixed. I attached  the one that would not load earlier, and again here, as T1a.nii

The machine is Dell Precision Win 10
Nov 23, 2018  01:11 PM | Larry Olson - Emory University
RE: Some imageswill notload in BIS web
As I mentioned before, the T1.nii file is OK- it was already saved and fixed. The image that would not load was the original conversion "T1a.nii" which I attached earlier and again here. (I made a mistake and sent you the corrected image rather than the one that failed)

The conversion was done on Win 10 Del precision
Attachment: T1a.nii
Nov 23, 2018  02:11 PM | Xenophon Papademetris
RE: Someimageswill notload in BIS web
Yes. Thanks. It looks like the data was byte swapped for whatever reason, so I have to flip the byte order to get it to look OK.

Try this out on the “unstable” version of the software now (never use this for anything, this is sort our internal build when we want to test something before we push it out to the main page).

https://bioimagesuiteweb.github.io/unsta...

This will be merged into the stable version early next week hopefully (it if works!)

Xenios
Nov 26, 2018  05:11 AM | Larry Olson - Emory University
RE: Someimageswill notload in BIS web
Thank you. Yes this version will load the images into the web viewer. I am mostly interested in the command line tools, so I will look forward to trying those.
Nov 26, 2018  10:11 AM | Xenophon Papademetris
RE:Someimageswill notload in BIS web
The test binary page is at http://bisweb.yale.edu/binaries2/
[Again these are mostly for internal testing purposes - the "stable" versions are in http://bisweb.yale.edu/binaries/)
Direct Link: http://bisweb.yale.edu/binaries2/bisweb-...

If you are curious, you can run the regression tests that come with this. Follow the instructions in ${INSTALL_DIR}/bisweb/test/README_test.md
Nov 27, 2018  05:11 PM | Larry Olson - Emory University
RE:Someimageswill notload in BIS web
Thank you so much. Looks like the test binaries do not include a winbin folder, and unfortunately I am working with a Windows machine. I can wait. But I will definitely look forward to your updates.
Nov 28, 2018  06:11 AM | Xenophon Papademetris
RE:Someimageswillnotload in BIS web
I am confused. The winbin scripts are there in the command line tools distribution

http://bisweb.yale.edu/binaries2/bisweb-...
Nov 28, 2018  07:11 AM | Larry Olson - Emory University
RE:Someimageswillnotload in BIS web
You are correct, thanks