help > Autoseg running problem!
Jan 20, 2016  10:01 AM | lei shi
Autoseg running problem!
Autoseg is a really good software. I am now using the AutoSeg 3.2 to do registration process by using monkey data from the UNC.  I found that there are several problems:
When i run it they always report error like attachment error. Also the Autoseg parameter is the same lie before, my parameters are below:
// Automatic Segmentation Parameter File

// Atlases
Common Coordinate Image: /Users/shilei/Documents/MRI_Paper/MonkeyAtlas_used_forT1/ABC_skull/templateSkull.nrrd
Common Coordinate Image Type: T1
Tissue Segmentation Atlas Directory: /Users/shilei/Documents/MRI_Paper/MonkeyAtlas_used_forT1/ABC_skull
Tissue Segmentation Atlas Type: T1
// Loop
Loop: 1
Atlas Loop: /Users/shilei/Documents/MRI_Paper/MonkeyAtlas_used_forT1/ABC_stripped/
Loop - Number of iterations: 1
ROI Atlas File: /Users/shilei/Documents/MRI_Paper/MonkeyAtlas_used_forT1/rhesusMonkeyT1_RAI/template.nrrd
// Subcortical Structures
Subcortical Structure Segmentation: 0
Amygdala Left:
Amygdala Right:
Caudate Left:
Caudate Right:
Hippocampus Left:
Hippocampus Right:
Pallidus Left:
Pallidus Right:
Putamen Left:
Putamen Right:
Lateral Ventricle Left:
Lateral Ventricle Right:
// Generic ROI Maps
Generic ROI Segmentation: 1
ROI File 1: /Users/shilei/Documents/MRI_Paper/MonkeyAtlas_used_forT1/SubCortical.gipl.gz
ROI File 2:
ROI File 3:
ROI File 4:
ROI File 5:
// Parcellation Maps
Parcellation Map Segmentation: 1
Tissue Map: Hard
Parcellation File 1: /Users/shilei/Documents/MRI_Paper/MonkeyAtlas_used_forT1/template_parc.gipl.gz
Parcellation File 2:
Parcellation File 3:
// Tissue Segmentation
EM Software: ABC
Filter Iterations: 10
Filter TimeStep: 0.01
Filter Method: Curvature flow
Max Bias Degree: 4
Initial Distribution Estimator: robust
Prior 1: 1.3
Prior 2: 1
Prior 3: 0.7
Prior 4: 1
Prior 5: 1
Fluid Atlas Warp: 1
Fluid Atlas Affine: 0
Fluid Atlas FATW: 0
Fluid Atlas Warp Iterations: 50
Fluid Atlas Warp Max Step: 0.1
Atlas Linear Mapping: affine
Image Linear Mapping: id
// Grid Template
Rigid Registration: 1
Is ROIAtlasGridTemplate: 1
GridTemplate SizeX: 0
GridTemplate SizeY: 0
GridTemplate SizeZ: 0
GridTemplate SpacingX: 0
GridTemplate SpacingY: 0
GridTemplate SpacingZ: 0
Registration Initialization: useCenterOfHeadAlign
Use T1 initial transform: 0
// Atlas Warping
Warping Method: BRAINSDemonWarp
// - Fluid Warping parameters
Alpha: 0.01
Beta: 0.01
Gamma: 0.001
Max Perturbation: 0.5
NumBasis: 0.01
Scale 4 - Number Of Iterations: 50
Scale 2 - Number Of Iterations: 25
Scale 1 - Number Of Iterations: 100
// - BRAINSDemonWarp parameters
Registration Filter Type: LogDemons
Deformation Field Smoothing Sigma: 2
Pyramid Levels: 5
Moving Shrink Factors: 16,16,16
Fixed Shrink Factors: 16,16,16
Iteration Count Pyramid Levels: 300,50,30,20,15
// - ANTS parameters
ANTS Iterations:
ANTS CC weight: 0
ANTS CC region radius: 0
ANTS MI weight: 0
ANTS MI bins: 0
ANTS MSQ weight: 0
ANTS Registration Type:
ANTS Registration Step:
ANTS Gaussian Smoothing: 0
ANTS Gaussian Sigma: 0
// Skull Stripping
Delete Vessels: 0
// Intensity Rescaling
Intensity Rescaling: Histogram quantile
// Regional histogram
Quantiles: 1,5,33,50,66,95,99
Point Spacing: 10
// N4 ITK Bias Field Correction
N4 ITK Bias Field Correction: 1
N4 Number of iterations: 50,40,30
N4 Spline distance: 0
N4 Shrink factor: 4
N4 Convergence threshold: 0.0001
N4 BSpline grid resolutions: 1,1,1
N4 BSpline alpha: 0
N4 BSpline beta: 0.5
N4 Histogram sharpening: 0
N4 BSpline order: 3
// Reorientation
Reorientation: 0
Input Orientation:
Output Orientation:
Does any one could give me some suggestions about Autoseg performance? Really appriciated any response!
best,
lei
Attachment: autoseg.tiff

Threaded View

TitleAuthorDate
Autoseg running problem!
lei shi Jan 20, 2016
Martin Styner Jan 21, 2016
lei shi Jan 22, 2016