users > Trouble with reading .nrrd in Windows
Feb 14, 2018  09:02 AM | Ingrid Framås Syversen
Trouble with reading .nrrd in Windows
Hello,

I am trying to perform EPI unwarping in the Windows command line (CMD.EXE), but I have encountered a problem.

First, I type in:
epiunwarp --write-jacobian-fwd epiunwarp/jacobian_fwd.nii \
inputs/b0_fwd.nii.gz inputs/b0_rev.nii.gz \
epiunwarp/b0_fwd.nii epiunwarp/b0_rev.nii epiunwarp/dfield.nrrd
This step works just fine. Then I type in:
reformatx --floating inputs/b1.nii --linear -o epiunwarp/b1.nii \
epiunwarp/b0_fwd.nii epiunwarp/dfield.nrrd
This gives me an error message: "The file/directory epiunwarp/dfield.nrrd does not exist or cannot be read."
I am sure that the file exists, so there must be some kind of problem reading the file. My operative system is Windows 7. I have tried the same thing in Cygwin (on the same computer), and there it works perfectly fine. However, I am going to do the EPI unwarping in another program (in MeVisLab, using an "External Executable Wrapper"), and I don't think that can be done via Cygwin. Therefore, I want this to work using only the Windows command line.

I am very not very familiar with using command line tools. However, a solution that fixed one of my earlier problems (missing .dll file) was installing a Visual C++ Redistributable, so I tried installing all of them, but that didn't help. Or is it possible to completely omit the problem by having the deformation field in another file format than .nrrd?

Does anyone know what might have gone wrong here?

Best,
Ingrid
Threaded View
Title
Author
Date
Trouble with reading .nrrd in Windows
Feb 14, 2018