help > Estimation failed, missing contrasts error
Jun 15, 2019  04:06 AM | Lewis Dunne
Estimation failed, missing contrasts error
Hi Donald, we spoke the other month via email and you were assisting with me setting up/using your gPPI toolbox. I thought I would start a proper thread here to continue that discussion.

I'm facing the error in the title and wonder if you could help:

Estimation Failed
Warning: Missing conditions!!! Invalid Contrast
Invalid Contrast
Warning: Missing conditions!!! Invalid Contrast
Invalid Contrast
PPI Contrasts were not estimated for some reason.

Here is my parameter structure P and I have also attached the SPM.mat:

P.subject='SME_TEST';
P.directory=pwd;
P.VOI=[pwd filesep 'VOI_dPPC_1.mat'];
P.Region='VOI_dPPC_1';
P.Estimate=1;
P.contrast=13;
P.extract='eig';
P.Tasks={'1' 'SR_search' 'SF_search' 'SR_capture', 'SF_capture'};
P.Weights=[];
P.analysis='psy';
P.method='cond';
P.CompContrasts=1;
P.Weighted=0;
P.Contrasts(1).left={'SR_search'};
P.Contrasts(1). right={'SF_search'};
P.Contrasts(1).STAT='T';
P.Contrasts(1).Weighted=0;
P.Contrasts(1).MinEvents=1;
P.Contrasts(1).name='SR_search-SF_search';
P.Contrasts(2).left={'SF_search'};
P.Contrasts(2).right={'SR_search'};
P.Contrasts(2).STAT='T';
P.Contrasts(2).Weighted=0;
P.Contrasts(2).MinEvents=1;
P.Contrasts(2).name='SF_search-SR_search';

As a brief summary, I have 4 conditions in the design matrix, and each subject has 4 runs. The conditions are based on (1) an attention mode manipulation (Search vs Capture), and (2) subsequent memory status (SR vs SF). So the four regressors are SR_search, SF_search, SR_capture, SF_capture. For practice using the gPPI toolbox I have a directory with a couple of subjects copied & pasted into it and the SPM file I've attached is for just one of those practice subjects. 

Kind regards
Lewis
Attachment: SPM.mat