open-discussion > RE: Is there a way to leave the B0's between the other DWI data in their place after using DTIPrep?
May 8, 2020  01:05 AM | Daniel Berge - Hospital del Mar Medical Research Institute (IMIM)
RE: Is there a way to leave the B0's between the other DWI data in their place after using DTIPrep?
Hi Martin, Thanks for your answer,
 
      Both b0 images are removed during the slice-wiise process. It happens for all subjects, and b0 images seem to be ok when visually inspected. I modified the protocol to run only sice-wise and the problem is there. Both b0 are excluded as it is reported in the QCReport.txt and in the xml file. I am attaching the txt report.
 I guess I could use the GUI , open the xml results file and mark the b0 images as "included" after visual inspection, but doing this process for each subject would be time consuming. I hope there is another way.

Thanks in advance.

Originally posted by Martin Styner:
Quick clarification question:
- are there no (0) b0 after DTIPrep or just 1 b0 (the first volume)?
- given your description, it's not an issue of the b0 averaging (since that is turned off), but the slice-wise check removes all b0's (you can see that in the output report or in the output xml)?

Martin
Originally posted by Daniel Berge:
Hi, I am experiencing exactly the same problem. I have double cheked (visual inspected) b0 images and they are completely fine. I unselect average b0 options and it does not change behavior. For any reason, during slice wise cheking, it detects bad correlation levels between slices of the b0 images (first and last volumes). 
  I tried to increase baseline slice-wise threhsold to sd=6, but it keeps on removing b0 volumes (slices with zscore around -3.7 to -5.). Interestengly it only detects slices with negative Z correlations. 

any suggestion about how to tell DTIPrep to preserve b0 volumes?

Best regards,
Dani Bergé
Originally posted by Martin Styner:
Originally posted by Puck Reeders:
 Hi everyone, 

When I use DTIPrep for my DWI QC, it deletes all my B0 files. 
I tried to turn off the averaging of the B0 files by turning the  "baseline_averaging" to "No", but for some reason all my B0 files are gone after I use DTIPrep. I am not using the eddy/motion correction in DTIPrep. I know that needs the averaged B0.
Any recommendations on how to use DTIPrep and keeping my B0 files in place?
Thank you in advance!

Best,

Puck Reeders
If you turn off baseline averaging, then it should not replace all of your b=0 with the average b=0, so all you b=0 volumes should still be present.  Please try again (and ensure that it writes to a new output folder) with baseline averaging disabled.

btw, the eddy motion correction uses the first b=0 as target. If baseline averaging is enabled, then that is the first b=0 volume. baseline averaging is not needed but recommended for eddy motion correction

One last comment: it could also be that the b=0 volumes are all low quality and thus get rejected in the slice-wise or interlace check? You should be able to see that from the QC report txt file

Martin

Threaded View

TitleAuthorDate
Puck Reeders Mar 25, 2020
Martin Styner Mar 25, 2020
Daniel Berge May 7, 2020
Martin Styner May 7, 2020
RE: Is there a way to leave the B0's between the other DWI data in their place after using DTIPrep?
Daniel Berge May 8, 2020
Martin Styner May 8, 2020