open-discussion > RE: Installation Error_QT4 issue
Nov 9, 2021  02:11 PM | Martin Styner
RE: Installation Error_QT4 issue
Yeah, unfortunately DTIPrep needs Qt4 (which is a bit outdated). DTIPrep will soon be replaced with an updated new framework called dmriprep which will combine the functionality of DTIPrep with eddy/topup in FSL 6 and that tool will no longer need Qt4.

For your immediate problem, you will need to compile DTIPrep with Qt4, i.e. you need to install a Qt4 package on your machine (you can multiple Qt versions installed)

Martin
Originally posted by neda mohammadi:
Dear Experts,
Hi,

I'm traying to install DTI-Prep on Ubuntu 20.04 alongside other software such as MRTrix, but because of QT4 issue, I  haven't installed it yet.
I followed these commands:

1. git clone https://github.com/NIRALUser/DTIPrep.git
2. mkdir DTIPrep-build; cd DTIPrep-build
3. cmake ../DTIPrep
4. make

But in step 3 I get error about QT4 and annoconda that has QT5 ......

would you please let me know how can I have DTI-Prep on Ubuntu 20.04 and/or alongside MRTrix if it is possible?

Thanks
Neda

Threaded View

TitleAuthorDate
neda mohammadi Oct 23, 2021
RE: Installation Error_QT4 issue
Martin Styner Nov 9, 2021
neda mohammadi Nov 11, 2021