users > RE: CMTK fails with no error or signal messages, "Ran 0 initial affine registrations of which 0 failed"
Jun 19, 2020  12:06 PM | Greg Jefferis
RE: CMTK fails with no error or signal messages, "Ran 0 initial affine registrations of which 0 failed"
Hi George,

This is an issue relating to the munger script which is a contribution (by me) outside the core CMTK library.

There is actually no error message in what you paste below. munger just can't find anything to do. This suggests to me that you do not have any appropriate input images inside the images folder or possibly that there are outputs in the output folder that are tricking munger into thinking that you have already completed running the registrations. Can you show us the contents of /home/george/Documents/expt/yourregistrationfolder?

ls -R /home/george/Documents/expt/yourregistrationfolder

All the best,

Greg.

Originally posted by george yerou:
Dear CMTK user community,

When I run CMTK it fails and doesn't provide any error messages to suggest why, below I have outlined the output I receive:

george@george-VirtualBox:~/Documents/expt/yourregistrationfolder$ "/home/george/Fiji.app/bin/cmtk/munger" -b "/home/george/Fiji.app/bin/cmtk" -a -w -r 010203 -X 26 -C 8 -G 80 -R 4 -A '--accuracy 0.4' -W '--accuracy 0.4' -T 1 -s "refbrain/JRC2018_U.nrrd" images
hostname = george-VirtualBox; short hostname = george-VirtualBox
JOB ID =
Root directory is /home/george/Documents/expt/yourregistrationfolder
Changing to root directory: /home/george/Documents/expt/yourregistrationfolder
Setting image root to: images
Ran 0 initial affine registrations of which 0 failed
Ran 0 affine registrations of which 0 failed
Ran 0 warp registrations
Reformatted 0 images

I have installed 2* versions of CMTK - one with the "install cmtk" option in fiji and one compiled from source following the steps outlined by Dr Torsten.
I get the same output when I replace -b "/home/george/Fiji.app/bin/cmtk (which refers to the fiji binaries) with -b "/home/george/cmtk/build/bin" (which refers to binaries from the compiled CMTK version). Using the compiled version looked like it was working yesterday, however I cancelled the operation and when I tried rerunning it I haven't had any success since. 

*I may also have a third version associated with the docker container for natverse I have installed.
I have been posting on the NBLAST FAQ page but thought this might be a more appropriate forum for this question.

I would be immensely grateful for any help!

Threaded View

TitleAuthorDate
george yerou Jun 19, 2020
RE: CMTK fails with no error or signal messages, "Ran 0 initial affine registrations of which 0 failed"
Greg Jefferis Jun 19, 2020
george yerou Jun 21, 2020