help > Problem with running the code
Jun 13, 2012  05:06 PM | Hengameh Mirzaalian
Problem with running the code
I am trying to apply ShapeWorks on my dataset. The following two command lines work properly.
ShapeWorksGroom ".\\A.preprocess1.params"  isolate  hole_fill  center  auto_crop
ShapeWorksGroom  ".\A.preprocess2.params"  antialias  fastmarching  blur
however, when I run
ShapeWorksRun   ".\\A.correspondence.params"
I receved the following error:
 itk::ExceptionObject (00FCFB2C)
Location: "bool __thiscall itk::ParticleImplicitSurfaceDomain::ApplyCon
straints(class itk::Point &) const"
File: c:\documents and settings\cates\desktop\shapeworks\code\itkparticlesystem\
Line: 121
Description: itk::ERROR: ParticleImplicitSurfaceDomain(01486510): A Point, [46.9
793, -0.00222205, 18.976], was projected outside the given image domain.
Further, ShapeWork works well when I run it over TorusExample dataset, but, when I run it on MickeyExample, it get stuck at particle count: 2 for this command line:
ShapeWorksRun   "".\\MickeyExample\\mickey.group1.correspondence.params"
Would you please guide me how to figure out these problems?

Threaded View

Problem with running the code
Hengameh Mirzaalian Jun 13, 2012
Manasi Datar Jun 13, 2012
Hengameh Mirzaalian Jun 14, 2012
Manasi Datar Jun 14, 2012
FĂ©lix Renard Aug 1, 2013