help > reference to non-existent field?
Apr 6, 2021  03:04 PM | nikolov
reference to non-existent field?
Hello, 

I'm attempting to develope a pipeline for ROI to ROI analyses on 5 subjects (full dataset is 200 subjects).  I have successfully imported the preprocessing functional and structural files using Tools > From FMRIPrep dataset.  

I have imported the Schaefer400 parcellation as my atlas file.  
The only preprocessing step I've executed is functional smoothing with a 6mm Gaussian kernel.  

Setup and Denoising run successfully, however when I get to 1st level analysis I am consistently presented with two error messages that state that I have a reference to non-existent fields, either 'Y' or 'X1'.  

Example of errors below: 

ERROR DESCRIPTION:

Reference to non-existent field 'Y'.
Error in conn (line 7458)
if isfield(CONN_h.menus.m_analyses.Y,'issurface')&&CONN_h.menus.m_analyses.Y.issurface, issurface=true; else issurface=false; end
CONN20.b
SPM12 + DEM FieldMap MEEGtools
Matlab v.2020b
project: CONN20.b
storage: 939.2Gb available

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

ERROR DESCRIPTION:

Reference to non-existent field 'X1'.
Error in conn (line 7347)
[CONN_h.menus.m_analyses.X,CONN_h.menus.m_analyses.select,names]=conn_designmatrix(CONN_x.Analyses(ianalysis).regressors,CONN_h.menus.m_analyses.X1,[],{nregressors,nview});
Error in conn (line 6401)
conn gui_analyses;
Error in conn (line 6639)
conn('gui_analysesgo',1);
CONN20.b
SPM12 + DEM FieldMap MEEGtools
Matlab v.2020b
project: CONN20.b
storage: 939.2Gb available


###########################################################################################

May I ask what may be causing this error?